puppet module dependency both met and unmet

puppet module dependency both met and unmet,puppet,Puppet,I'm getting a warning from puppet about an unmet dependency, and yet it appears the dependency is met. I'm more than a bit confused about this error message. Can anyone offer any tips or pointers? ubuntu@seine2:/vagrant$ sudo puppet module list Warning: Missing dependency 'puppet-yum': 'puppet-collectd' (v5.2.0) requires 'puppet-yum' (>= 0.9.15) Warning: Missing dependency 'puppetlabs-apt': 'puppet-collectd' (v5.2.0) requires 'puppetlabs-apt' (>= 2.2.0) /etc/puppet/modules ├── golja

I'm getting a warning from puppet about an unmet dependency, and yet it appears the dependency is met. I'm more than a bit confused about this error message. Can anyone offer any tips or pointers?

ubuntu@seine2:/vagrant$ sudo puppet module list
Warning: Missing dependency 'puppet-yum':
  'puppet-collectd' (v5.2.0) requires 'puppet-yum' (>= 0.9.15)
Warning: Missing dependency 'puppetlabs-apt':
  'puppet-collectd' (v5.2.0) requires 'puppetlabs-apt' (>= 2.2.0)
/etc/puppet/modules
├── golja-gnupg (v1.2.3)
├── jfryman-nginx (v999.999.999)
├── maestrodev-rvm (v1.13.1)
├── puppet-collectd (v5.2.0)
├── puppet-staging (v2.0.1)
├── puppet-yum (v0.9.15)
├── puppetlabs-apt (v2.3.0)
├── puppetlabs-concat (v2.2.0)
├── puppetlabs-firewall (v1.8.1)
├── puppetlabs-mysql (v3.10.0)
├── puppetlabs-stdlib (v4.14.0)
├── puppetlabs-vcsrepo (v1.5.0)
├── saz-locales (v2.2.2)
└── saz-memcached (v2.8.1)
/usr/share/puppet/modules (no modules installed)
ubuntu@seine2:/vagrant$ 

Note that

puppet-yum
is already at the required 0.9.15 and
puppetlabs-apt
is at 2.3.0 which is greater than the 2.2.0 required.


#1

Ah, this is a bug.

It is reported at #17251 and as is also discussed here.

It has been fixed in puppet 4.0.0, but I am using (ubuntu 16.04 LTS) 3.8.5.

I am still somewhat unclear if the warnings matter (besides being quite ugly). I think the answer is that they don't, simply because I haven't had anything fail yet.


#2

You can run the latest version of Puppet on 16.04 quite easily. Just install it via gem.

#3

I agree with you that the warnings are spurious and have no effect on catalog building. Also, do not lightly undertake an upgrade from Puppet 3.x to Puppet 4. You should plan on making that change eventually, but it's a major-version upgrade, and chances are good that something will break.

#4

@JohnBollinger Thanks for the warning. I've been experimenting with parser=future in order to be able to use epp files, and even that small attempt is causing a few bits of pain!