Ubuntu CURAND_STATUS_LAUNCH_FAILURE: caffe installation

Ubuntu CURAND_STATUS_LAUNCH_FAILURE: caffe installation,ubuntu,caffe,pycaffe,nvidia-digits,Ubuntu,Caffe,Pycaffe,Nvidia Digits,I had already installed Cuda 7.5 and now I have installed Cuda 8.0. The Nvidia card is TITAN X (Pascal). I also only activated the following compute abilitiesCUDA_ARCHfield inmakefile.config` (the rest are commented): -gencode arch=compute_52,code=sm_52 \ -gencode arch=compute_61,code=sm_61 \ -gencode arch=compute_61,code=compute_61 I successfully could run make all and make test for Caffe installation, however, when I tried to run make runtest after some time it is showing error: F0509 11:1

I had already installed

Cuda 7.5
and now I have installed
Cuda 8.0
. The Nvidia card is
TITAN X (Pascal). I also only activated the following compute abilities
CUDA_ARCH
field in
makefile.config` (the rest are commented):

-gencode arch=compute_52,code=sm_52 \
-gencode arch=compute_61,code=sm_61 \
-gencode arch=compute_61,code=compute_61

I successfully could run

make all
and
make test
for
Caffe
installation, however, when I tried to run
make runtest
after some time it is showing error:

F0509 11:19:15.078367 29181 math_functions.cu:416] Check failed: status == CURAND_STATUS_SUCCESS (201 vs. 0)  CURAND_STATUS_LAUNCH_FAILURE

When I type

ldd ./build/tools/caffe | grep cuda
, I get

libcudart.so.7.5 => /usr/lib/x86_64-linux-gnu/libcudart.so.7.5 (0x00007fd3ea210000)
    libicudata.so.55 => /usr/lib/x86_64-linux-gnu/libicudata.so.55 (0x00007fd3c9f3c000)

How to remove *.so of cuda7? or what is possible solution?Thanks


#1

I could solve this issue by uninstalling Nvidia cuda toolkit. I followed the command here . I reinstalled cuda 8.0 and added the following paths to .bashrc:

export PATH=/usr/local/cuda-8.0/bin${PATH:+:${PATH}}
export LD_LIBRARY_PATH=/usr/local/cuda-8.0/lib64${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}

#2

Seems like this question is for another site in StackExchange.

#3

@Inman Thanks for your comment, I could solve the issue

#4

See github.com/NVIDIA/caffe/issues/270

#5

@LukeYeager Thanks for your help. I could solve it by uninstalling and reinstalling cuda toolkit as I have brought here as answer.